After years of searching, I was able to locate an untested IBM 5170 motherboard about 2 hours away. Being untested, of course I was taking my chances. But I was able to get it working. Here’s how I fixed my IBM 5170 motherboard so I could restore my IBM 5170 with a true-blue IBM board to replace the clone board in it.

Disclaimer

IBM 5170 motherboard

I got this 5170 motherboard untested at a fairly good price. It took a good month to get running, but it runs now.

Every broken 35-year-old motherboard is different. I make no guarantees what worked on mine will work on yours. I present my experience hoping it may help you.

Initial impressions

I received a type 3 board, which was the last revision before the 5170 gave way to the PS2 line. It was in good cosmetic shape. Before powering it on, I checked for continuity between the ground and all of the power rails on the power connector. Finding none, I concluded it would be safe to power on.

I connected a video card and a POST card. The latter is important for diagnosing old boards. The board powered up and gave codes, so it wasn’t completely dead. But it wouldn’t boot. All I got were a beep sequence that wasn’t documented anywhere, and a blinking cursor that advanced down the screen. It never got to a memory test.

I observed that the keyboard controller was the version with a programmable EPROM in it, and the window was uncovered. That’s a no-no. And one of the POST codes pointed to a keyboard error. I swapped the keyboard with a known good one just to be sure, but it wasn’t that easy in this case.

So I concluded I had a bad keyboard controller. Other POST codes pointed to other chips on the board. By the time I was done running through all the POST codes, I had concluded I would need to desolder and replace at least three chips. The problem was, every time I powered up the system, it gave different errors. So it wasn’t at all consistent. That’s when I asked for help.

The diagnostic ROM

Modem 7, a user on the Vintage Computer Federation, answered my query for help. He noted that inconsistency isn’t unusual on a 5170. He recommended I burn a diagnostic ROM and try running it.

The diagnostic gave different results than my POST card. It pointed to memory. Unfortunately, it works best with CGA, and while I thought I had a couple of CGA cards kicking around somewhere, I couldn’t find either of them. So I had to rely on the speaker, which couldn’t tell me where the memory problem was, only that I had one.

Modem 7 said he thought I’d probably need to replace all 18 memory chips. Fortunately for me, they are all socketed. He also suggested it was possible I had bad bios roms, based on the inconsistent behavior. So he suggested I try burning a new set of ROMs.

Quadtel to the rescue

Rather than burn another set of stock ROMs, I burned a set of Quadtels. Their bios works in a 5170 and is more user-friendly. I figured it might be easier to get the board running with it, then switch back to the original IBM BIOS.

This ended up really helping. With the Quadtel BIOS installed, it went straight to a memory test, and only counted 128k. This board had 512k. So that confirmed the diagnostic ROM. Also, the keyboard worked. The lesson there: beware of confirmation bias.

So I ordered a batch of memory chips, enough to replace all 18 and still leave some spares. But I figured while I waited, I might as well pry the old chips off the board. Then serendipity happened. One of the chips landed face down, and I noticed pin 1 didn’t look right. It looks fine in the socket, but when it was faced down, I could see the pin was broken off and the stub was bent under the chip body. That’ll break something. I straightened the stump, and there was enough left that it looked like it might work. All other 17 chips looked fine.

The chips didn’t all match. 16 of the 18 were newer and faster than the two parity chips. I can only conclude the machine had a memory issue, but not a parity issue, so someone tried replacing memory, messed up one chip, and couldn’t get the board working and decided to scrap the board. Then, 30 years later, they sold the board as untested.

When I replaced the memory, I put the bad chip in the top left socket and painted a white dot on it so I would know which one to replace when the new memory chips arrive. But in the meantime, why not see what happened?

I powered it on, and it counted to 512. Happy dance. I ran set up, configured the drives, and it booted. I wanted to test the memory, so I ran check it, which has a good memory test that works on a 286. Yes, there are better tests available for newer processors, but I have no way to use one of those.

I let check it run overnight, well it’s most thorough memory test, and I didn’t have any problems. I will still replace that chip, but I know I have a working board. And without needlessly replacing a bunch of soldered chips, and risking board damage given my very mediocre soldering skills.

Restoring the IBM BIOS

There are two schools of thought regarding the 5170 BIOS. The original IBM BIOS has a lot of limitations. You have to run setup from a floppy, its self-test is not great, its compatibility isn’t great, and the biggest hard drive it can use is 118 MB. Replacing it with a newer one from a third party is a very nice upgrade from the original.

But some argue that BIOS is what makes an IBM an IBM. For one thing, if it fails to boot, it drops into IBM cassette Basic. Install a third party one, and it just acts like any other generic 286 clone.

I at least wanted to see if I could get the system to work with the IBM one. I ran out of EPROMs, so while I waited for more to arrive, I decided to try the original chips again. Lo and behold, they worked.

Lessons learned

If you have a broken 5170 board, I definitely recommend you try the Landmark diagnostic ROMs in it, and try one of the aftermarket BIOS sets known to work in it. There are several. You will need an EPROM burner, but at $48, they quickly pay for themselves.

I spent more than I needed to getting this board running, but it’s a hobby. The EPROM burner is something I’ve been meaning to get for a long time anyway, and I’ll use the RAM chips in other projects.