Home » Jerry Pournelle » Page 3

Jerry Pournelle

10/31/2000

I know there’s a word for this
I know ’cause we’ve all at some time said it
like when we were little kids
we’d fight each other ’til someone would give in
and you’d make him tell you ‘uncle’
  –Aimee Mann, “I Know There’s a Word” (Whatever, 1993)

Those lyrics came to mind the instant I read this.  My talkback is #22. There’s little point in reproducing any of it here.

I had a run-in with Mr. Darren (I recognize his style) the summer before last. Typical story Jerry tells. Jerry talks about Apple attack dogs who leap on anyone who dares write anything negative about Apple. Same principle here. Eventually you reach the point where you get sick of it and therefore don’t write anything at all about the subject to avoid the attack dogs.

The ignorance these people display about how computer journalism and the computer industry itself operate is unbelievable. Is it so unusual to learn something about a subject before opening your mouth about it?

This kind of crap makes me glad that now I’m not writing a book about Linux and Windows that might actually suggest that some people might have reason to run Windows. Oh, hell. I’ll go ahead and say it. Attention zealots: You know what software your beloved O’Reilly uses to write and edit its manuscripts? Microsoft Word!

On to a more pleasant subject. Good thing there’s a whole lot more to life than just computers. A friend called me up and told me to make sure I picked up the November issue of Vanity Fair because of a brief Aimee Mann/Michael Penn feature in it, plus Elvis Costello’s Top 500 recommended CDs. Good stuff. The issue kept me distracted from my article (due ASAP) for the better part of an hour.

Elvis’ best line: “As for the hit records of today, maybe some of them will sound just fantastic in 20 years’ time. It’s your life. So! No Marilyn, Korn, Puffy, Eddie Money–sorry, Kid Rock–Limp Bizkit, Ricky, Britney, Backstreet Boys, etc., etc.”

Here here!

Mail later. Probably. Assuming I bother.

It’s later. In March of 1999, Jerry was having some or another Linux problem, he got mail-bombed, and I sent him a letter, addressing him but also the Linux zealotry, asking, “What do you want? Do you want to be a punk computer like the Amiga, that no one uses? Repeat after me: Criticism of Linux is not a personal attack on me.” Jerry printed it, the result was a lot of mail.

One of them was this letter, to which I started writing a response but never got around to finishing because I couldn’t figure out what he wanted from me. This is, I’m pretty certain, the same “Darren” who wrote the “Jerry Pournelle finally admits he’s a Microsoft shill” headline at Linuxtoday.

I believe that what he and others like him are calling for is not journalism, nor is it editorial (which is where you call it like you see it–technically, that’s what Jerry Pournelle does. He’s a columnist, not a journalist) but rather, sheer advocacy.

I present it here. Opinions welcome–the mail link’s to the left, and you can leave comments by clicking on the skull icon at the end of the message (that’s what that’s for–I just haven’t gotten around to changing it).

From: Darren [SMTP:PCTech1018@netscape.net]Sent: Thursday, March 11, 1999 11:09 AM
Subject: RE: Your letter on Chaos Manor

Dave,

You asked the question “What do Linux Users want?”.

We want ACCURATE reporting.  This does not mean that we do not accept negative commentary.  This means that we are sick and tired of people with obvious Microsoft slants propagating unsubstantiated FUD while claiming journalistic objectivity.

Jerry Pournelle has a long history of being pro-microsoft.  His negative comments about Linux have a history of being based in ignorance. When he first started working with Linux and complaining about the lack of usability of Linux, he hadn’t even gotten a Linux system up and running. Why does he want Linux to continue to exist? So that Microsoft will continue to improve and dominate. These are demonstrable facts.

Journalists have continually spread anti-Linux FUD from Microsoft most often without any basis in fact. Until recently, the “difficult to use” argument was the predominant position. KDE, FVWM and other “easy-to-use” interfaces have existed for YEARS. This FUD has only recently been dying off after Microsoft’s demonstration of Caldera in court. There is the “lack of support” FUD argument. This FUD is finally dying off now that IBM, HP, Compaq, et al, have joined in the Linux “support” bandwagon. What is really ironic is that they are simply repackaging and using the same support mechanisms that have existed since the introduction of Linux 1.0 in 1994. Now we have a concentration of the “lack of applications” FUD. As more people become aware of HOW to use the sites such as www.linuxapps.com and www.metalab.unc.edu, this argument will also become apparent for the FUD that it is.

What do Linux users want? We want techno-journalists who do more than simply repeat the latest FUD out of Redmond.  They claim to have a certain level of expertise in the technical arena, but are most often only successful at demonstrating their own ignorance.

You obviously feel that we have been out of line in our treatment of certain journalists.  Would you care to give me an example of negative Linux reporting that was accurate from Jesse Berst, Jerry Pournelle or Ben Elgin? How about you give me any example at all from ANY journalist?

I am confident that I will be able to take any example you give me and show you how it is slanted, inaccurate, and not worthy of being published by professional journalists.

I do not intend this to be a flame mail, I just want to do my part to kill the bad journalism.

Regards,
Darren

I also have some (very lengthy) mail from someone who I believe is taking a much more constructive approach, or at least whose criticisms are much more valid. That should appear soon.

Scanner troubleshooting secrets

~Mail Follows Today’s Post~

Scanner wisdom. One of the things I did last week was set up a Umax scanner on a new iMac DV. The scanner worked perfectly on a Windows 98 PC, but when I connected it to the Mac it developed all sorts of strange diseases–not warming up properly, only scanning 1/3 of the page before timing out, making really loud noises, crashing the system…

I couldn’t resolve it, so I contacted Umax technical support. The tech I spoke with reminded me of a number of scanner tips I’d heard before but had forgotten, and besides that, I rarely if ever see them in the scanner manuals.

  • Plug scanners directly into the wall, not into a power strip. I’ve never heard a good explanation of why scanners are more sensitive to this than any other peripheral, but I’ve seen it work.
  • Plug USB scanners into a powered hub, or better yet, directly into the computer. USB scanners shouldn’t need power from the USB port, since they have their own power source, but this seems to make a difference.
  • Download the newest drivers, especially if you have a young operating system like MacOS 9, Mac OS X, Windows ME, or Windows 2000. It can take a little while for the scanner drivers to completely stabilize. Don’t install off the CD that came with the scanner, because it might be out of date. Get the newest stuff from the manufacturer’s Web site.
  • Uninstall old drivers before installing the new ones. This was the problem that bit me. The new driver didn’t totally overwrite the old one, creating a conflict that made the scanner go goofy.
  • Buy your scanner from a company that has a track record of providing updated drivers. Yes, that probably means you shouldn’t buy the $15 scanner with the $25 mail-in rebate. Yes, that means don’t buy HP. Up until a couple of years ago, getting NT drivers out of HP was like pulling teeth; now HP is charging for Windows 2000 drivers. HP also likes to abandon and then pick back up Mac support on a whim. Terrible track record.

Umax’s track record is pretty darn good. I’ve downloaded NT drivers for some really ancient Umax scanners after replacing old Macs with NT boxes. I once ran into a weird incompatibility with a seven-year-old Umax scanner–it was a B&W G3 with a wide SCSI controller (why, I don’t know) running Mac OS 8.6. Now that I think about it, I think the incompatibility was with the controller card. The scanner was discontinued years ago (before Mac OS 8 came out), so expecting them to provide a fix was way out of line.
m I’ve ever had with a Umax that they didn’t resolve, so when I spec out a scanner at work, Umax is always on my short list.

And here’s something I just found interesting. Maybe I’m the only one. But in reading the mail on Jerry Pournelle’s site, I found this. John Klos, administrator of sixgirls.org, takes Jerry to task for saying a Celeron can’t be a server. He cites his 66 MHz 68060-based Amiga 4000, which apparently acts as a mail and Web server, as proof. Though the most powerful m68k-based machine ever made, its processing power pales next to any Celeron (spare the original cacheless Celeron 266 and 300).

I think the point he was trying to make was that Unix plays by different rules. Indeed, when your server OS isn’t joined at the hip to a GUI and a Web browser and whatever else Gates tosses in on a whim, you can do a lot more work with less. His Amiga would make a lousy terminal server, but for serving up static Web pages and e-mail, there’s absolutely nothing wrong with it. Hosting a bunch of Web sites on an Amiga 4000 just because I could sounds very much like something I’d try myself if I had the hardware available or was willing to pay for the hardware necessary.

But I see Jerry Pournelle’s point as well.

It’s probably not the soundest business practice to advertise that you’re running off a several-year-old sub-100 MHz server, because that makes people nervous. Microsoft’s done a pretty admirable job of pounding everything slower than 350 MHz into obsolescence and the public knows this. And Intel and AMD have done a good job of marketing their high-end CPUs, resulting in people tending to lay blame at the CPU’s feet if it’s anything but a recent Pentium III. And, well, if you’re running off a shiny new IBM Netfinity, it’s very easy to get it fixed, or if need be, to replace it with another identical one. I know where to get true-blue Amiga parts and I even know which ones are interchangeable with PCs, but you might well be surprised to hear you can still get parts and that some are interchangeable.

But I’m sure there are far, far more sub-100 MHz machines out there in mission-critical situations functioning just fine than anyone wants to admit. I know we had many at my previous employer, and we have several at my current job, and it doesn’t make me nervous. The biggest difference is that most of them have nameplates like Sun and DEC and Compaq and IBM on them, rather than Commodore. But then again, Commodore’s reputation aside, it’s been years since I’ve seen a computer as well built as my Amiga 2000. (The last was the IBM PS/2 Model 80, which cost five times as much.) If I could get Amiga network cards for a decent price, you’d better believe I’d be running that computer as a firewall/proxy and other duties as assigned. I could probably get five years’ uninterrupted service from old Amy. Then I’d just replace her memory and get another ten.

The thing that makes me most nervous about John Klos’ situation is the business model’s dependence on him. I have faith in his A4000. I have faith in his ability to fix it if things do go wrong (anyone running NetBSD on an Amiga knows his machine better than the onsite techs who fix NetFinity servers know theirs). But there’s such thing as too much importance. I don’t let Apple certified techs come onsite to fix our Macs anymore at work, because I got tired of them breaking other things while they did warranty work and having to fix three things after they left. I know their machines better than they do. That makes me irreplaceable. A little job security is good. Too much job sercurity is bad, very bad. I’ll be doing the same thing next year and the year after that. It’s good to be able to say, “Call somebody else.” But that’s his problem, not his company’s or his customers’.

~~~~~~~~~~

From: rock4uandme
To: dfarq@swbell.net
Sent: Wednesday, October 25, 2000 1:22 PM
Subject: i`m having trouble with my canon bjc-210printer…

i`m having trouble with my canon bjc210 printer it`s printing every thing all red..Can you help???
 
 
thank you!!    john c
 
~~~~~~~~~

Printers aren’t my specialty and I don’t think I’ve ever seen a Canon BJC210, but if your printer has replacable printheads (some printers make the printhead part of the ink cartridge while others make them a separate component), try replacing them. That was the problem with the only Canon printer I’ve ever fixed.
 
You might try another color ink cartridge too; sometimes those go bad even if they still have ink in them.
 
If that fails, Canon does have a tech support page for that printer. I gave it a quick look and it’s a bit sketchy, but maybe it’ll help. If nothing else, there’s an e-mail address for questions. The page is at http://209.85.7.18/techsupport.php3?p=bjc210 (to save you from navigating the entire www.ccsi.canon.com page).
 

I hope that helps.

Dave
 
~~~~~~~~~~
 

From: Bruce Edwards
Subject: Crazy Win98 Networking Computer Problem

Dear Dave:

I am having a crazy computer problem which I am hoping you or your readers
may be able to give me a clue to.  I do have this posted on my daily
journal, but since I get very little traffic, I thought your readership or
yourself may be able to help.  Here’s the problem:

My wife’s computer suddenly and inexplicably became very slow when accessing
web sites and usually when accessing her e-mail.  We access the internet
normally through the LAN I installed at home.  This goes to a Wingate
machine which is connected to the aDSL line allowing shared access to the
internet.

My computer still sends and receives e-mail and accesses the web at full
speed.  Alice’s computer now appears to access the web text at about the
speed of a 9600 baud modem with graphics coming down even more slowly if at
all.  Also, her e-mail (Outlook Express) usually times out when going
through the LAN to the Wingate machine and then out over the internet. 
The LAN is working since she is making a connection out that way.

File transfer via the LAN between my PC and hers goes at full speed.
Something is causing her internet access to slow to a crawl while mine is
unaffected.  Also, it appears to be only part of her internet access.  I can
telnet out from her computer and connect to external servers very fast, as
fast as always.  I know telnet is just simple text, but the connection to
the server is very rapid too while connecting to a server via an http
browser is much much slower and then, once connected, the data flows so slow
it’s crazy.

Also, dial-up and connect to the internet via AOL and then use her mail
client and (external to AOL) browser works fine and is as speedy as you
would expect for a 56K modem.  What gives?

I tried reinstalling windows over the existing set-up (did not do anything)
and finally started over from “bare metal” as some like to say.  Reformat
the C drive.  Reinstall Windows 98, reinstall all the drivers, apps, tweak
the configuration, get it all working correctly.  Guess what?  Same slow
speed via the aDSL LAN connection even though my computer zips out via the
same connection.  Any suggestions?

Sincerely,

Bruce W. Edwards
e-mail:  bruce@BruceEdwards.com
Check www.BruceEdwards.com/journal  for my daily journal.

Bruce  🙂
Bruce W. Edwards
Sr. I.S. Auditor  
~~~~~~~~~~

From: Dave Farquhar [mailto:dfarq@swbell.net]Sent: Monday, October 23, 2000 6:16 PM
To: Edwards, Bruce
Cc: Diana Farquhar
Subject: Re: Crazy Win98 Networking Computer Problem

Hi Bruce,
 
The best thing I can think of is your MTU setting–have you run any of those MTU optimization programs? Those can have precisely the effect you describe at times. Try setting yor MTU back to 1500 and see what that does. While I wholeheartedly recommend them for dialup connections, MTU tweaking and any sort of LAN definitely don’t mix–to the point that I almost regret even mentioning the things in Optimizing Windows.
 
Short of that, I’d suggest ripping out all of your networking protocols and adapters from the Network control panel and add back in TCP/IP and only the other things you absolutely need. This’ll keep Windows from getting confused and trying to use the wrong transport, and eliminate the corrupted TCP/IP possibility. These are remote, but possible. Though your reinstall should have eliminated that possibility…
 
If it’s neither of those things, I’d start to suspect hardware. Make sure you don’t have an interrupt conflict (rare these days, but I just saw one a couple weeks ago so I don’t rule them out). Also try swapping in a different cable or NIC in your wife’s machine. Cables of course go bad more frequently than NICs, though I’ve had horrible luck with cheap NICs. At this point I won’t buy any ethernet NIC other than a Bay Netgear, 3Com or Intel.
 
I hope that helps. Let me know how it goes for you.

Dave 
~~~~~~~~~~
From: Bruce Edwards

Hi Dave:
 
Thank you for posting on your web site. I thought you would like an update.
 
I verified the MTU setting was still at 1500 (it was).  I have not used one of the optimizing programs on this PC.
 
I removed all the adapters from the PC via the control panel.  Rebooted and only added back TCP/IP on the Ethernet card. 
 
I double checked the interrupts in the control panel, there do not appear to be any conflicts and all devices report proper function.
 
I still need to 100% verify the wiring/hubs.  I think they are O.K. since that PC, using the same adapter, is able to file share with other PCs on the network.  That also implies that the adapter is O.K.
 
I will plug my PC into the same hub and port as my wife’s using the same cable to verify that the network infrastructure is O.K.
 
Then, I’ll removed the adapter and try a different one.
 
Hopefully one of these things will work.
 
Cheers,
 
Bruce
~~~~~~~~~~

This is a longshot, but… I’m wondering if maybe your DNS settings are off, or if your browser might be set to use a proxy server that doesn’t exist. That’s the only other thing I can think of that can cause sporadic slow access, unless the problem is your Web browser itself. Whichever browser you’re using, have you by any chance tried installing and testing the other one to see if it has the same problems?
 
In my experience, IE 5.5 isn’t exactly the greatest of performers, or when it does perform well, it seems to be by monopolizing CPU time. I’ve gotten much better results with IE 5.0. As for Netscape, I do wish they’d get it right again someday…
 
Thanks for the update. Hopefully we can find an answer.

Dave 
~~~~~~~~~~ 

Abandoned intellectual property

Abandoned Intellectual Property. I read a piece on this subject at OSOpinion over the weekend, and I’ve been thinking about it ever since. There are, of course, a lot of people calling for abolition of copyright or radical changes. This is, believe it or not, one of the tamer proposals I’ve read.

I’m definitely of two minds on this one. Take my first ever publication for money, in 1991. Compute Magazine, before Bob Guccione had managed to totally ram it into the ground, opted to buy my spring break project I collaborated on with a friend. We were writing a video game for the Commodore 64 and 128 and we were getting tired of trying to draw the title screen manually with graphics commands (bad enough on the 128 which had Basic commands to do such things, but on the 64 you were talking peeks and pokes all over the place–someone really should have written this thing back in 1982!) so we wrote a program to do the work for us. You loaded the sprites, moved ’em around, hit a key, and it gave you the Basic code to re-create the screen, suitable for inclusion in your program. We never finished the game, but we got a cool $350 and international recognition (OK, so it was a dwindling audience, but how many high school kids can say they’re published authors at age 16?).

Now, the problem. General Media whittled Compute down until it was basically just another PC mag, abandoning the multiplatform support that made it so great (I read about my beloved Commie 8-bits but still got the opportunity to learn about Macs, Amigas and PCs–what could be better?), market share continued to dwindle, and eventually Guccione and GM sold out to Ziff-Davis, who fulfilled your subscription with a choice of mags (I remember I opted for PC/Computing). So the copyright went to Ziff-Davis, who never did anything with the old Compute stuff. A few years later, Ziff-Davis fell on hard times and eventually hacked itself up into multiple pieces. Who owns the old Compute stuff now? I have no idea. The copyrights are still valid and enforcable. I seriously doubt if anyone cares anymore whether you have the Nov. 1991 issue of Compute if you’re running MOB Mover on your 64/128 or emulator, but where do you go for permission?

The same goes for a lot of old software. Sure, it’s obsolete but it’s useful to someone. A 68020-based Mac would be useful to someone if they could get software for it. But unless the original owner still has his/her copies of WriteNow, Aldus SuperPaint and Aldus Persuasion (just to name a few desirable but no-longer-marketable abandoned titles) to give you, you’re out of luck. Maybe you can get lucky and find some 1995 era software to run on it, but it’ll still be a dog of a computer.

But do we have an unalienable right to abandoned intellectual property, free of charge? Sure, I want the recordings Ric Ocasek made with his bands before The Cars. A lot of people want to get their hands on that stuff, but Ocasek’s not comfortable with that work. Having published some things that I regret, I can sympathize with the guy. I like how copyright law condemns that stuff to obscurity for a time. (Hopefully it’d be obscure in the public domain too because it’s not very good, but limiting the number of copies that can exist clinches it.)

Obscurity doesn’t mean no one is exploited by stealing it. I can’t put it any better than Jerry Pournelle did.

I don’t like my inability to walk into record stores and buy Seven Red Seven’s Shelter or Pale Divine’s Straight to Goodbye or The Caulfields’ Whirligig, but I couldn’t easily buy them in 1991 when they were still in print either. But things like that aren’t impossible to obtain: That’s what eBay and Half.com are for.

For the majority of the United States’ existence, copyright law was 26 years, renewable for another 26. This seems to me a reasonable compromise. Those who produce content can still make a living, and if it’s no longer commercially viable 26 years later, it’s freely available. If it’s still viable, the author gets another 26-year-ride. And Congress could sweeten the deal by offering tax write-offs for the premature release of copyrighted material into the public domain, which would offer a neat solution to the “But by 2019, nobody would want WriteNow anymore!” problem. Reverting to this older, simpler law also solves the “work for hire” problem that exploits musicians and some authors.

All around, this scenario is certainly more desirable for a greater number of people than the present one.

From: Bruce Edwards

Dear Dave:

I am having a crazy computer problem which I am hoping you or your readers may be able to give me a clue to.  I do have this posted on my daily journal, but since I get very little traffic, I thought your readership or
yourself may be able to help.  Here’s the problem:

My wife’s computer suddenly and inexplicably became very slow when accessing web sites and usually when accessing her e-mail.  We access the internet normally through the LAN I installed at home.  This goes to a Wingate machine which is connected to the aDSL line allowing shared access to the internet.

My computer still sends and receives e-mail and accesses the web at full speed.  Alice’s computer now appears to access the web text at about the speed of a 9600 baud modem with graphics coming down even more slowly if at
all.  Also, her e-mail (Outlook Express) usually times out when going through the LAN to the Wingate machine and then out over the internet.  The LAN is working since she is making a connection out that way.

File transfer via the LAN between my PC and hers goes at full speed. Something is causing her internet access to slow to a crawl while mine is unaffected.  Also, it appears to be only part of her internet access.  I can
telnet out from her computer and connect to external servers very fast, as fast as always.  I know telnet is just simple text, but the connection to the server is very rapid too while connecting to a server via an http
browser is much much slower and then, once connected, the data flows so slow it’s crazy.

Also, dial-up and connect to the internet via AOL and then use her mail client and (external to AOL) browser works fine and is as speedy as you would expect for a 56K modem.  What gives?

I tried reinstalling windows over the existing set-up (did not do anything) and finally started over from “bare metal” as some like to say.  Reformat the C drive.  Reinstall Windows 98, reinstall all the drivers, apps, tweak the configuration, get it all working correctly.  Guess what?  Same slow speed via the aDSL LAN connection even though my computer zips out via the
same connection.  Any suggestions?

Sincerely,

Bruce W. Edwards

~~~~~~~~~~

Hi Bruce,

The best thing I can think of is your MTU setting–have you run any of those MTU optimization programs? Those can have precisely the effect you describe at times. Try setting yor MTU back to 1500 and see what that does. While I wholeheartedly recommend them for dialup connections, MTU tweaking and any sort of LAN definitely don’t mix–to the point that I almost regret even mentioning the things in Optimizing Windows.

Short of that, I’d suggest ripping out all of your networking protocols and adapters from the Network control panel and add back in TCP/IP and only the other things you absolutely need. This’ll keep Windows from getting confused and trying to use the wrong transport, and eliminate the corrupted TCP/IP possibility. These are remote, but possible. Though your reinstall should have eliminated that possibility…

If it’s neither of those things, I’d start to suspect hardware. Make sure you don’t have an interrupt conflict (rare these days, but I just saw one a couple weeks ago so I don’t rule them out). Also try swapping in a different cable or NIC in your wife’s machine. Cables of course go bad more frequently than NICs, though I’ve had horrible luck with cheap NICs. At this point I won’t buy any ethernet NIC other than a Bay Netgear, 3Com or Intel.

I hope that helps. Let me know how it goes for you.